What is needed to address bug#1601, Excel and Powerpoint file timestamp changes?

David Pullman dpullman at cme.nist.gov
Thu Feb 3 20:44:46 GMT 2005

Gerald (Jerry) Carter wrote:
> Please let me know if this is really an issue with 3.0.11rc1 tomorrow.
> We're planning on releasing 3.0.11 final on Friday and this is the
> first report I've heard of something like you describe.
> You might also want to try the SAMBA_3_0_RELEASE branch which has a few 
> small updates since 3.0.11rc1 and is what will eventually become the final 
> release.
> Details on downloading source code via anonymous svn are at
> http://www.samba.org/samba/devel/
> Thanks.
> cheers, jerry

OK, I ran the current patch cluster for Solaris 9 and reran the tests on 
3.0.11rc1.  As the owner of a powerpoint file I can open it but as the 
member of a group, on a file with 666 perms, I can only get read-only 
privs.  3.0.10 on the same shares with the same smb.conf works fine.

Here's the smb.conf:

# Global parameters
         workgroup = MELAD
         realm = MEL.NIST.GOV
         netbios name = BOOGIE
         server string = Test Server: Samba 3.0.X
         security = ADS
         smb passwd file = /etc/samba/private/smbpasswd
         private dir = /etc/samba/private
         syslog = 0
         log file = /var/spool/samba/%m
         log level = 10
         max log size = 0
         preferred master = No
         local master = No
         domain master = No
         wins server =
         disable spoolss = yes
         ldap ssl = no
         lock directory = /etc/samba/var/locks
         pid directory = /var/run
         hosts allow = 129.6.70., 129.6.32., 129.6.33., 129.6.34., 
129.6.35., 129.6.36., 129.6.37., 129.6.132.
         # creation masks
         # files
         create mask = 0644
         force create mode = 0000
         map archive = no
         map hidden = no
         map system = no
         # directories
         directory mask = 0755
         force directory mode = 0000

         # security masks
         # files
         security mask = 0777
         force security mode = 0000
         # directories
         directory security mask = 0777
         force directory security mode = 0000

#       inherit permissions = yes

         path = /export/testdir
         read only = No

         path = /export/rational
         write list = dnfowler

The setup is basically the same as we've run for several years, with 
only the new settings to join the AD domain.  This is an Ultra 10 with 
SunOS5.9, we use NIS for authentication for UNIX, AD on a Windows server 
for Windows.  Every username is duplicated in each authentication 
server.  All groups are enumerated in NIS.

I use exactly the same build process, same libraries, etc., for every 
version of 3.0.x.

I ran a simple test case to capture a level 10 log, first with 3.0.11rc1 
and then with 3.0.10.  I stopped the server, erased /var/spool/samba, 
set the link for /opt/samba for rc1, started the server, connected to 
the share, went into a directory, opened a .ppt, closed it, closed the 
share, stopped the server.  Saved the log, then reran with 3.0.10.

If you would like, please let me know what I may send such as logs, etc.

I'll be trying the same tests with 3_0_RELEASE and 3.0.11pre2 later 
tonight or tomorrow.  Have to leave for class.


More information about the samba-technical mailing list