What is needed to address bug#1601, Excel and Powerpoint file timestamp changes?

David Pullman dpullman at cme.nist.gov
Thu Feb 3 04:12:27 GMT 2005

Gerald (Jerry) Carter wrote:

>Hash: SHA1
>On Wed, 2 Feb 2005, David Pullman wrote:
>>Bug# 1601 was created on 08/11/2004, and appended to by three other 
>>people besides the original submitter.  It is still in a "new" status. 
>>While it is difficult to say for sure (there are many different reports 
>>related to "timestamps"), this seems to have been reported several times 
>>in the past.
>>Is there something needed that might get this assigned?  We have a 
>>couple of divisions that are suggesting they migrate to Windows servers 
>>because they need timestamping to work correctly with their 
>>presentations and spreadsheets. We know that this behaviour is occuring 
>>on our production 2.2.8a servers, and we can duplicate it on current 
>>testing of 3.0.10.  We tried checking 3.0.11 but the rc1 release seems 
>>to have group permissions broken (a user in the group with rw can only 
>>open .ppt or .xls as read-only; only the owner can open the file 
>>writable.)  We have also tried this on W2K file servers and while the 
>>modified timestamp changes when a file is opened, it reverts when closed 
>>with no changes.
>Have you tested 3.0.11rc1 ?  This sounds like it should be fixed by 
>one of jeremy's changes.  The one that fixed the "file may be open by 
>another user" error message with Excel.
>cheers, jerry
>Version: GnuPG v1.2.5 (GNU/Linux)
>Comment: For info see http://quantumlab.net/pine_privacy_guard/

As I mentioned, we wanted to try 3.0.11rc1, and built it the same way as 
we've built every 3.0.x release on Solaris 9 with krb5 and openldap, 
etc.  But when we ran the tests we couldn't get write priv for anyone 
except the owner.  Even with mode 666 the members of the file's group 
could only get powerpoint or excel to open read-only.  In the level 3 or 
higher logs you would see the file opened and closed repeatedly, with 
write=No except one time every attempt.  For some reason, one time in 
the midst of a slew of opens and closes, there would be one case of 
write=Yes.  Anyway, the result was always read-only unless you were the 

We stopped the server, and started the server with 3.0.10, same 
smb.conf, and the same files worked fine for the group members.  Except 
for the mod time changes :P

I'll run rc1 again tomorrow after I try pre2, and I'll post the smb.conf 
and level 10s if you would like?  I know how much you like Solaris, so 
I'm sure you'ld like to see them :)

Also, please note that this behaviour is both powerpoint and excel, and 
is not related to saving a file, only an open and a close.  It doesn't 
prompt to save or anything, it just closes and the timestamp changes.


More information about the samba-technical mailing list