Samba4 - unable to join a workstation

Stefan (metze) Metzmacher metze at
Tue Aug 16 06:13:39 GMT 2005

Hash: SHA1

Holger Schmieder schrieb:
> Hallo all,
> i am trying to join a workstation to an samba4 ADS-Controller.
> With Win2K and WinXP it is working, i see a new entry in the ldap-store. Anyhow, after a reboot the machine can't logon to the domain - i get the message "the computer-account is missing or the password is invailid"
> In the debug-log i only see ldap-searches to my domain with successfull results. There are no searches for the computers-name.
> If i check the Machines-entry for the joined-domain i can see, that the workstation is joined to the realm (in my example schmieder3.intra) instead to the domain (SCHMIEDER3).
> This whas my provisioning command:
> setup/provision --realm=SCHMIEDER3.INTRA --domain=SCHMIEDER3 --adminpass=xxxxx

We were yet not able to create a valid PAC in the krb5 ticket that windows clients accept,
we're working hard on this...

> Also i tried it with WinNT (SP6a + DS-Client) - completly unsuccessfull !

We haven't tried that yet

> What i see to: the domain is not browsable - i can logon to the server with the administrator-account but i cannot see the domain in my Network-enviroment.
> Is there a special entry in smb.conf to make the domain browsable. Here my smb.conf:

yep the browser service is not yet implemented in samba4

> [globals]
>         netbios name    = lab04
>         workgroup       = SCHMIEDER3
>         realm           = schmieder3.intra
>         domain master   = yes
>         domain logons   = yes
>         netbios aliases = lab04
>         preferred master = Yes
>         os level        = 65
>         wins server     =
>         time server = Yes
> [test]
>         path = /daten/test
>         read only = no

looks ok

- --

Stefan Metzmacher <metze at>
Version: GnuPG v1.2.3-nr1 (Windows XP)
Comment: Using GnuPG with Thunderbird -


More information about the samba-technical mailing list