cli_reg_create_key_ex() dcerpc fault

Chris Nicholls cnicholl at
Mon Aug 8 01:41:04 GMT 2005


I was testing cac_RegCreateKey() (which calls cli_reg_create_key_ex) and 
I found that it always fails.  At first I thought I was doing something 
wrong, but after a while of it not working I fired up Ethereal to see 
what was happening, and I found that the server (a winxp machine) is 
responding to the CreateKey with a DCERPC fault.

I tried to create the key from another windows machine and it worked. I 
made another ethereal capture from the windows machine and compared it 
with the original dump.  The most noticeable difference is that the 
request from cac_RegCreateKey() is 76 bytes larger than the windows 
one.  I figured that something about the request getting sent out isn't 
quite right, so I messed around a little with reg_io_q_create_key_ex() 
but I ended up getting nowhere.

Any help/advice/comments ?

I can send the ethereal captures, or (i'm guessing) the problem can be 
re-produced by running libmsrpc/test/regkeycreate in the SOC/SAMBA_3_0 


More information about the samba-technical mailing list