VFS - Making A File copy

Chetana chetana at fstream.net
Fri Oct 1 13:06:09 GMT 2004

The file copying seems to work finenow. I was using the same inode number
sbuf->st_ino = 1 for every stat , fstat and lstat calls. This was solved by
changing sbuf->st_ino = fd * 10 for fstat .
However I am still using sbuf->st_ino = 1 for all stat and lstat calls.
On seeing from explorer I get "file inaccessible" or "disk full" error
while trying to modify word documents .I wonder if this dummy inode is the
And I have set "locking = no" in smb.conf.
Any suggestions are more than welcome.
Thanks and Regards,

Have you tried disabling locking? Samba can handle internally locking if
the system do not support it.

> The file access mode is
> 	sbuf->st_mode = S_IRWXU | S_IROTH | S_IXOTH
> and the directory access mode is
> 	sbuf->st_mode = S_IFDIR | S_IRWXU | S_IROTH | S_IXOTH
> Also I get the (SMBlockingX) NT_STATUS_RANGE_NOT_LOCKED error when I try
> modify any
> word document or any other microsoft related file(PPT,excel etc...).Does
> this mean I need to implement
> file locking? If yes can someone suggest how to implement a minimal dummy
> file locking function?

No need, if you donot support it, just disable it in the share through
proper smb.conf options.

More information about the samba-technical mailing list