[Samba] cifs problems with multiple linux boxes hitting W2K shares, cifs-1.20c-2.4, linux 2.4.27 kernel

Joe samba at cleanh2o.com
Mon Nov 1 22:41:36 GMT 2004

First of all - thanks to the cifs developers!

We have 2 load balanced web servers behind a firewall.
Each of these servers has 5 W2K shares mounted for access by apache.
When I tried to convert all of those mounts from smbfs to cifs on port 445
the mounts became unstable. And apache caused a kernel oops and I had to
reboot - a couple of times while I was working on this. I had run one
of the machines using cifs mounts fine for 1 week before trying the other.
Then - ouch........

Today, I finished converting all of the smbfs mounts on the machines to
cifs. I had all but the busiest 2 mounts converted as of Friday. I had to
stop apache to umount those.

I used port 139 as suggested by Steve French. I'd like to know why port
445 doesn't work. Perhaps it would if the domain was specified. But I've
crashed the production machines enough already and don't want to try that
again. Because we have 2 load balanced servers and use lvs and mon to
access them, hundreds of library staff and thousands of users didn't know
I was having problems and crashing the machines. I plan to leave things
alone for now.....

The mounts look like they are working fine. No CIFS errors. Lots of files
are being accessed via apache and I did simultaneous listings and copies
of a mounted image directory (~2500 files, ~270MB) to the machines. When
I had major problems the last times that I tried the conversion, the
problems showed up immediately. A couple of times the machines went down
before I could react.

* findings
 - when cifs was called out to run on port 445 on both machines it blew up
 - specifying port 139 on both machines appears to work - although one
   of them seems to be using port 445 (according to netstat)
 - specifying the domain in the credentials file (user at LIB.UW.EDU) doesn't
   work consistantly, I included it as a mount option
 - a working fstab entry: //server.lib.uw.edu/webshare /mnt/web cifs \
    ro,credentials=/usr/local/etc/cifs.cred,port=139, \
    file_mode=0444,dir_mode=0555,rsize=8192,domain=LIB.UW.EDU 0 0
 - to be determined

UW Libraries

More information about the samba-technical mailing list