Multiple AD Password Servers

Klinger, John (N-CSC) john.klinger at
Thu Mar 25 03:40:24 GMT 2004

Solaris 8; Samba 3.0.1 smbd, nmbd, and winbindd; security=ads; openldap idmap backend.

We've been running with a couple of ADs specified in our password server like:

password server = activedsvr  activedsvr2

This has worked wonders until tonight, when we tested against a machine that
couldn't resolve activedsvr2 (no /etc/hosts or DNS entry). Unfortunately,
winbindd doesn't work unless it can contact both, staying in a loop attempting
to find activedsvr2 and not servicing pam.conf, nsswitch, or clients. As soon as I
add activedsvr2 to the /etc/hosts file, winbindd flies along merrily. I can even
then punt one of the servers and winbindd will still continue working.

Unfortunately, I'm going to be working on this tomorrow, and hopefully have
it solved the same day. So I'd *truly* appreciate input on whether winbindd's
"I won't start until I find all the password servers" is by design. I'm hoping
it is hanging on just the name resolution and not the server being down. I'll
be checking that tomorrow, too.

Thanks for your comments. 

More information about the samba-technical mailing list