Solaris NSS problem, only seeing few winbind groups

ww m-pubsyssamba pubsyssamba at
Wed Mar 3 17:39:23 GMT 2004

I have discovered the following additional detail on the behaviour being exhibited by Solaris,

When I run "getent group" many groups which are visable from "wbinfo -g" are not displayed.
But if I run "getent group groupname" against a groupname which is not displayed by "getent group"
I can see the group, and all group members!
But if I do "logins -m -l username" or "id -a username" for a user in a problem group, the user is
not listed as having the problem group as a secondary group?!?
And the user has no access to files or folders permissioned rwx to the problem group.

Perhaps not the same as your bug Luke?

	thanks Andy.

>Does this problem only occur on Solaris? 
>Potentially this is related to: <> 
>-- Luke 

Hi Luke,

	thanks for your interest, yes this problem only seems to occur with Solaris and
does look like the same issue on your bug.
I've tested this on RedHat Linux and the problem is not present. But I see this problem
on Solaris 8 & 9. I've logged a support call with Sun but I need help pointing them to
and diagnosing the problem. If anyone can provide any assistance, or give me any
ammunition to get Sun to recognise a problem then I'd be very grateful,

	thanks Andy.

BBCi at

This e-mail (and any attachments) is confidential and may contain personal views which are not the views of the BBC unless specifically
If you have received it in error, please delete it from your system. Do not use, copy or disclose the information in any way nor act in
reliance on it and notify the sender immediately. Please note that the BBC monitors e-mails sent or received.
Further communication will signify your consent to this.

More information about the samba-technical mailing list