Cannot change win2003 domain user's password with smbpasswd

Andrew Bartlett abartlet at
Thu Feb 12 20:41:13 GMT 2004

On Fri, 2004-02-13 at 04:28, Gerald (Jerry) Carter wrote:
> Hash: SHA1
> Lin Li wrote:
> | Hi,
> |
> | I cannot change the win2003 domain user's password with smbpasswd.
> | I  always get "machine 2003server1 rejected the password change:
> | Error was:  RAP86: The specified password is invalid.". Win2000
> | domain works fine.  Anyone tried it with success? I use 3.0.0
> | and also tried the code from cvs.
> I thought there was a bug report about this.  But if not,
> please file one so we can get it addressed.  Thanks.

This might well be fixed in 3.0.3 CVS.  The server probably doesn't take
LM passwords any more, and probably also demands authentication for the
password change.  

I've addressed both these points in 3.0.3, but not actually aimed it at

Andrew Bartlett

Andrew Bartlett                                 abartlet at
Manager, Authentication Subsystems, Samba Team  abartlet at
Student Network Administrator, Hawker College   abartlet at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url :

More information about the samba-technical mailing list