Problems with Mac files?

Ashley M. Kirchner ashley at
Thu Aug 5 17:13:00 GMT 2004

    I haven't gotten an answer from the general list with this problem, 
so maybe someone here can help me out and figure out what's going on.  
If this isn't the right place to post, I'll go back and repost it on the 
general list and hope someone can help.  Here are the two messages I 
posted on the general list:


   I have a Win2K Server that acts as a file server to a bunch of 
Macintosh machines on the network.  Today I installed samba-3.0.5 on a 
Fedora1 machine, and mounted one of the server shares and tried to read 
it.  Much to my surprise, I found files that are being listed like this:

-rwxr-xr-x  1 root root      0 May 13 16:30 Icon?*
-rwxr-xr-x  1 root root  25649 Aug 23  2000 webslide151.gif*
-rwxr-xr-x  1 root root  57619 Mar 26 08:22 ???webslide1581.JPG*
-rwxr-xr-x  1 root root  26132 Mar 26 08:22 webslide1631.JPG*
-rwxr-xr-x  1 root root  67711 Aug 18  1999 webslide176.gif*
-rwxr-xr-x  1 root root  70559 Mar 26 08:22 webslide1771.JPG*
-rwxr-xr-x  1 root root  80792 Mar 26 08:23 ???webslide1851.JPG*

   When looking at the files on the Win2K serer, they're fine - they can 
be opened with no problems or anything.  There are no extra characters 
on those file names, and yet samba displays them with ??? in the front.  
The "Icon?" is the folder icon resource that any Mac machine creates in 
any folder they dive in to.

   If I try to run a 'du' on the mount, I get errors like this:

$ du -h --max-depth=1
31G     ./ INKJET
132M    ./Font Library
du: cannot access `./ICON?': No such file or directory
680M    ./Jon S Folder
8.0K    ./Network Trash Folder
8.0K    ./RECYCLER

   If I run rsync on the mount (which is ultimately what's going to 
happen,) the first run gives me errors on the three "weird" files 
(Icon?, and the two that start with ???) and a second run will copy them 
over, as if nothing happened.


   Here are some more messages that pop in the server logs when I try to 
read folders on a Win2K file server - the folders/files were saved from 
a Macintosh on the network:

smb_proc_readdir_long: name=\Font Library\B\Bernhard BoldCond. et al?\*, 
result=-2, rcls=1, err=123
smb_proc_readdir_long: name=\Font Library\K\Kino, et al?\*, result=-2, 
rcls=1, err=123
smb_proc_readdir_long: name=\Font Library\K\Kunstler Schreibschrift?\*, 
result=-2, rcls=1, err=123
smb_proc_readdir_long: name=\Font Library\N\Nashville Lt?ExBd\*, 
result=-2, rcls=1, err=123
smb_proc_readdir_long: name=\Font Library\R\Rotis Semi?Serif\*, 
result=-2, rcls=1, err=123
smb_proc_readdir_long: name=\Font Library\R\Ruling Script et al?\*, 
result=-2, rcls=1, err=123


W | I haven't lost my mind; it's backed up on tape somewhere.
  Ashley M. Kirchner <mailto:ashley at>   .   303.442.6410 x130
  IT Director / SysAdmin / WebSmith             .     800.441.3873 x130
  Photo Craft Laboratories, Inc.            .     3550 Arapahoe Ave. #6 ..... .  .    .       Boulder, CO 80303, U.S.A.

More information about the samba-technical mailing list