LDAP Failover

Mike Samba samba at astroshapes.com
Wed Jul 16 12:31:21 GMT 2003

I tried this on the general mailing list and it was suggested to me to
ask the technical list for help on this...

I have tried samba3-beta1 and beta2 to authenticate against LDAP.  Both
versions have worked great until I attempt LDAP failover.  In my config,
if I try:

	ldap server = srv1.domain.com

It works perfect.  So does:

	ldap server = srv2.domain.com

But when I try:

	ldap server = srv1.domain.com srv2.domain.com

This completely halts the authentication process!!  I use ethereal to
watch the packets and LDAP packets never leave the server with this
config line.  In debug mode, samba spits back out:

	tree connect failed: NT_STATUS_ACCESS_DENIED

I also tried the newer method of:

	passdb backend = ldapsam_compat:ldap://srv1.domain.com

And it works great until I add the second server.

Is there something I am doing wrong?  I would really like to begin using
samba3 but the LDAP failover is a big holdback for me.


More information about the samba-technical mailing list