Bug in Samba 3.0 alpha21 in joining DOMAIN from WNT 4.0.

Fri Jan 31 18:46:35 GMT 2003

I have an samba-ldap configuration with SAMBA 3.0 alpha 21 (tarball no cvs).
I use patched version of smbldap-tools
from samba.idealx.org to be used with samba 3.0. 

I had two problems while joining to the domain from WINT 4.0 (serv pack 6)
client ( via netdom 1.7 cmd or via 
Control panel).

1) Adding the parameter "add machine script =
/usr/local/sbin/smbldap-useradd.pl -a -w "%u"" netdom fails
when changing the machine password on the PDC. Looking at the log ( at debug
level 100 ) samba seems 
to have invoked the script and then to have found machine account already
present with ldap attributes and fails.
It seems to me a different behaviour from samba 2.2 and in my opinion,
strange. Infact the version of smbldap-tools
I have enhaced, and which i hope i will release soon, to day allow to manage
globally SAMBA 3.0 ( including interdomain
trust and the ldap group <-> global samba Domain Group) without using "samba
net" command. I'd like to know any
good idea about it.

2) If i pre-create the machine account with smbldap-useradd.pl -a -w
TERMINAL everything works (netdom success)
but the AcctFlags being cancelled with everything that follow. I get the
same result if i execute the netdom
twice in succession ( the first fails as i said).

I get the same stuff if i use as passdb backed smbpasswd and i define the
"add machine script" as "useradd -d /dev/null
-g users -m "%u"".

Nevertheless i noticed that "netdom query" command always returns an error
even if the join to the domain worked correctly; in the
same situations netdom with alpha17 worked correctly.

I am  attaching the log files about the two kind of error and the smb.conf

Thanking you in advance for any coming help and i thank all the samba team
for you great work. I <<mytest.gzip>>  believe on it strongly.  

-------------- next part --------------
A non-text attachment was scrubbed...
Name: mytest.gzip
Type: application/octet-stream
Size: 78315 bytes
Desc: not available
Url : http://lists.samba.org/archive/samba-technical/attachments/20030131/d69582f9/mytest.obj

More information about the samba-technical mailing list