Samba and windows xp

Jalene Joyner Jalene.Joyner at
Thu Feb 20 15:38:36 GMT 2003

I have set up a server with Redhat linux version 7.3 running Samba
2.2.7...  initially this was configured using the SWAT.  This particular
server is not only a file server but a webserver and provides database
support through MySQL.  Shares and users have been set up and the system
has worked fine ever since.  From a Winxp client I can connect to the
server and work as though it was my hard drive.  So have a "setup" that
works and has continued to work.


In the meantime I have tried setting up two additional servers with the
same configuration software wise and for some reason we will have
connectivity through Samba for a 3-5 days then all the sudden I get
messages to the affect that I don't have permission to use the network
resource.  I know this sounds crazy but this happens all on its own.
Absolutely no changes were made on the server to cause this to happen.
I have talked to several people that were more experienced than I and I
had already tried their ideas.  BTW I have tried syncing all the
passwords/usernames and the problem is still there.


Below is what my smb.conf file looks like:


# Samba config file created using SWAT

# from localhost.localdomain (

# Date: 2003/02/20 08:22:26


# Global parameters


      workgroup = HDS

      netbios name = RH_TIC1

      server string = Samba Server

      security = DOMAIN

      encrypt passwords = Yes

      update encrypted = Yes

      obey pam restrictions = Yes

      pam password change = Yes

      passwd program = /usr/bin/passwd %u

      passwd chat = *New*password* %n\n *Retype*new*password* %n\n

      unix password sync = Yes

      log file = /var/log/samba/%m.log

      max log size = 0

      socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

      preferred master = False

      local master = No

      domain master = False

      dns proxy = No

      printing = lprng



      comment = Home Directories

      valid users = %S

      read only = No

      create mask = 0664

      directory mask = 0775

      browseable = No



      comment = All Printers

      path = /var/spool/samba

      printable = Yes

      browseable = No



      path = /tic1

      read only = No

      guest ok = Yes



Can one of you real techies tell me what to look for to correct this


More information about the samba-technical mailing list