3.0.1rc2 profile/unicode failures

James M Moya moyman at ecn.purdue.edu
Fri Dec 12 14:18:49 GMT 2003

After upgrading our test server from samba v2.2.8a to 3.0.1rc2 most profiles
would fail to load after authenticating. The error was mostly refering to 
the "3 1/2 Floppy (A:).lnk" file. There were others however, the Office "Recent" folder seemed to be popular as well. All were of the form:

Windows cannot copy file
\\pier\profile\pchome\.pcprefs\Profile\SendTo\3???????? to
location C:\Documents and Settings\tjmadm\SendTo\3????????.
Possible causes of this error include network problems or insufficient
security rights. If this problem persists, contact your network 

It seems to be a UTF8 issue. I installed libiconv v1.9.1 just so samba3.0.1rc2
would install without complaining (This is Solaris 8). I later tried v1.8
with the same result. I have some 19,000 accounts over 6TB of disk space that
samba serves up so this would be a sizable issue before we could deploy. Is this is know problem? What are the "fixes" if any. Here would be a "normal" smb.conf, fairly generic:

        workgroup = XXX
        log level = 1
        deadtime = 10
        socket options = TCP_NODELAY IPTOS_LOWDELAY
        printcap name = /etc/lp/smb_printerlist
        local master = No
        wins server = x.x.x.x
        remote announce = x.x.x.x
        remote browse sync = x.x.x.x

        comment = Home Directories
        path = %H/pchome
        read only = No
        browseable = No

        comment = User Profile
        path = %H
        read only = No
        create mask = 0600
        force create mode = 0600
        directory mask = 0700
        force directory mode = 0700
        browseable = No
        csc policy = disable


More information about the samba-technical mailing list