Word problem with large uid/gid

Johan Coenen johan.coenen at aiv.kuleuven.ac.be
Fri Apr 25 13:17:14 GMT 2003


We've noticed the following problem:

Samba server:

RedHat 7.3
Linux version 2.4.18-3 (bhcompile at daffy.perf.redhat.com)
(gcc version 2.96 20000731 (Red Hat Linux 7.3 2.96-110))
Samba 2.2.8a
1 user defined
1 share defined
(it's a test-setup, server is a Dell ProLiant 2600 and isn't used for 
anything else)

Client PC: Windows XP/Office97 and Windows2000/Office97

IF 	uid or gid of user > 65.535
AND	samba loglevel > 2
THEN 	I have problems with saving word documents
errors on client: "disk full" "read-only" etc...

Well, you might suggest that if that's our problem, we should use small 
uids/gids or shouldn't set the log-level higher than 2.
But the problem is that in our production environment, despite the fact 
that log levels are set to 1, some users are sometimes having the same 
problem with saving word-documents (Word97, Word2k and WordXP). Some do 
have large uid's en practically all are having large gid's
We tried all Samba versions 2.2.3 up to 2.2.8a, tried RH7.1, RH7.3, XFS 
1.0.1, XFS 1.1 and now Ext3

Colleagues of mine are saying "it can't be the kernel. It must be something 
in the Samba code"

Is there a reasonable explanation why, in our test-setup, log level 1 and 2 
don't give a problem, and all the other levels do?

Thanx in advance,



         netbios name = LS-AIV-96
         server string = Server AIV - Testserver
         workgroup = AIVTEST

         encrypt passwords = yes
         security = user
         guest account = nobody

         wins server = <ip address of wins server>

         local master = Yes
         preferred master = Yes
         domain master = Yes
         os level = 65

         log level = 10
         log file = /var/log/samba/%m.log
         max log size = 0
         timestamp logs = yes
         syslog = 1

         case sensitive = No
         show add printer wizard = No

         client code page = 850
         character set = ISO8859-1

;  ---------------------------------------------------------
;  Added the following lines after a tip I received
;  Problem is the same, whether with or without these lines	

         socket options = TCP_NODELAY SO_KEEPALIVE
         deadtime = 15
         keepalive = 10
         oplocks = no
         level2 oplocks = no
         read raw = no
         write raw = no
         getwd cache = yes
;  ---------------------------------------------------------

         path = /home/samba/aaa
         comment = test1
         browseable = Yes
         writeable = Yes
         force group = +aaa-w
         create mode = 664
         directory mode = 2775

More information about the samba-technical mailing list