[samba3-alpha23] Status of printers remains "Access denied, unable to connect"

Kristis Makris kristis.makris at datasoft.com
Sat Apr 12 00:38:36 GMT 2003

On Fri, 2003-04-11 at 13:53, Steve Langasek wrote:
> On Fri, Apr 11, 2003 at 01:29:19PM -0700, Kristis Makris wrote:
> > > > Has anyone been able successfully print with samba-alpha23+LDAP+cups, or
> > > > at least samba-alpha23+LDAP ?
> > > My SAMBA_3_0 (updated every day or so from CVS) print server / PDC 
> > > works fine using an OpenLDAP 2.1.9 server.  
> > Thanks for the info Jerry. Are you using cups, lpd, lprng ... ?
> To supplement Jerry's comment, I'm also using Samba 3.0 (3.0alpha23 with
> patches) with ldapsam and LPRng, and printing now works ok after a bit of
> patching.
> The only outstanding patch that has not yet been included in SAMBA_3_0
> affects SMB printing only, not RPC (spoolss) printing.

Thanks for all the help guys.

In case anyone has the same problem, here are my results of trial and

- I was missing a /var/spool/samba directory. I believe this solved the
"Access denied" problem, but removing the directory did not bring the
"Access denied" error back. Hmm...

- The RH7.3 cups package "cups-1.1.14-15.2" did not work for me. After
raising the Loglevel to debug in /etc/cups/cups.conf I noticed the
following line:

D [11/Apr/2003:17:24:47 -0700] inputfile handling is broken!!!inputfile
handling is broken!!! at /usr/lib/cups/filter/cupsomatic line 104.

I am able to sent print jobs to cups correctly, and cups spits out this
in /var/log/cups/error_log:

I [11/Apr/2003:16:40:29 -0700] Job 61 queued on 'hp4050' by 'makris_k'.
I [11/Apr/2003:16:40:29 -0700] Started filter
/usr/lib/cups/filter/cupsomatic (PID 31639) for job 61.
I [11/Apr/2003:16:40:29 -0700] Started backend
/usr/lib/cups/backend/socket (PID 31640) for job 61.

It also lists print jobs (through the Web interface on port 631) as
completed after submitted through Win2k clients, but never prints those

Setting the following lines solved this problem, as the cups api was
effectively bypassed:

   printcap name = /etc/printcap
   load printers = yes
   printing = bsd
   print command = /usr/bin/lpr -r -P %p -o raw %s 

This was documented also on other mailing lists.

- The "Add Printers" Wizard still does not list the printers made
available by the machine running samba3-alpha23+Steve's printing-23
patch, but should be unrelated.

- Using LPRng alltogether as the underlying printing daemon also worked.

More information about the samba-technical mailing list