samba-3.0alpha23 gives PANIC error on Printer Open

Kristis Makris kristis.makris at
Thu Apr 10 22:22:43 GMT 2003

> > I am using samba-3.0alpha23 compiled from source. I get an INTERNAL
> > ERROR and a PANIC error message in the
> > /var/log/samba/<somemachinename>.log, when I attempt to "Open" a printer
> > out of a list of printers configured in a Windows2000+SP3 workstation. I
> > have configured smb.conf to authenticate against an OpenLDAP server
> > provided by RH7.3's openldap-servers-2.0.27-2.7.3 package.
> > I need to mention that in the list of printers configure for the Win2K
> > machine, the entry for the particular printer I am trying to open shows
> > up with the comment "Access denied, unable to connect".
> Yes.  Attached please find the patch against 3.0alpha23 that I'm using.
> It appears there were three separate bugs that broke printing; and I'm
> still having issues after applying this patch that I'm in the process of
> pinning down.  I get the impression that the printing code isn't getting
> a /whole/ lot of testing on the 3.0 branch. :)

Thank you Steve, the patch solved the INTERNAL ERROR and PANIC bugs.

I don't know if the following means anything, or if it's one of the
other two bugs you mentioned, but one thing I noticed is that while
trying to add a printer using the "Add Printer" Wizard, I can never get
a listing of at least the <samba3-alpha23> machine (which contains 
printers shared out). If, however, I explicitly browse in
\\<samba3-alpha23srv> using "My Network Places" I can see all the
available printers shared out, and only by double clicking them can I
eventually get a prompt to install those to the local W2k machine.

The problem then is the "Access denied, unable to connect" error message
mentioned above. The printers appear installed locally, but still cannot
be opened. I'm still unsure as to what the reason for getting this error
might be. When trying to open the printers as a domain user who has been
assigned local Administrator privileges to the machine I still get
"Access denied". If I try as the domain administrator, I don't get the
"Access denied" status, but the status column reports the state
"Opening" indefinitely and printing a test page fails. Printing on the
printer from the linux side works correctly. smb.conf is configured with
the lines:

   printcap name = cups
   load printers = yes
   printing = cups

The same "Add Printers" Wizard properly shows all samba-2.0.10, and
samba-2.2.7 machines and the printers they share out, so this browsing
capability is definitely broken.

Hope this helps.


More information about the samba-technical mailing list