rpcclient/samlogon in Samba 3.0alpha9

Vijay Kota vijay at spinnakernet.com
Mon Sep 16 14:57:02 GMT 2002

I tried this with samba 3.0 alpha 19 as well - with the same results.
Wouldn't this cause a problem in a network where there are Win2K clients
as well as NT4 clients? Everybody would be forced to use NTLM then.
-----Original Message-----
From: samba-technical-admin at lists.samba.org
[mailto:samba-technical-admin at lists.samba.org] On Behalf Of Vijay Kota
Sent: Friday, September 13, 2002 1:19 PM
To: samba-technical at lists.samba.org
Subject: rpcclient/samlogon in Samba 3.0alpha9
I am seeing a strange problem with samba 3.0 alpha9. I joined my Linux
box to a Win2K realm. After this, I used rpcclient to do a samlogon. The
samlogon was successful but after this, the "servicePrincipalName"
attribute for the samba-server in the Active Directory was gone. Here's
what I tried:
       net ads join -U administrator
       ldapsearch -Y gssapi -X u:administrator samaccountname=SAMBA3$
       ---- output was HOST/samba3
       rpcclient testpdc -U administrator (and then "samlogon foo bar"
at the rpcclient prompt)
       ldapsearch -Y gssapi -X u:administrator samaccountname=SAMBA3$
       ---- no output
Any ideas as to why this doesn't work?
==============   My smb.conf  file ==============
  netbios name = SAMBA3
  server string = Running samba 3.0-alpha9
  workgroup = TESTDOM
  security = domain
  realm = REALM.COM
  ads server = testpdc
  interfaces =
  debuglevel = 10
  encrypt passwords = yes
  password server = testpdc
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba-technical mailing list