System documentation of Samba

Jeff Mandel jeff.mandel at
Thu Sep 5 14:59:00 GMT 2002

>Date: Thu, 5 Sep 2002 13:14:41 +0000
>From: jra at
>To: Johannes Tyve <Johannes.Tyve at>
>Cc: samba-technical at
>Subject: Re: System documentation of Samba
>On Thu, Sep 05, 2002 at 08:59:36AM +0200, Johannes Tyve wrote:
>>One of our servers crashed and when we booted it again one Samba process 
>>hung and grabbed one of the servers cpu's. When we killed the samba 
>>process, another process generated 100% load on one cpu. From the log 
>>  open_mode_check: exlusive oplock left by process 23227 after break ! For 
>>profile/.../office.file.doc, dev = 900, inode = 2704003. Deleting it to 
>>  PANIC: open_mode_check: Existant process 23227 left active oplock.
>>We tried to disable oplocks but no luck. After some more testing we 
>>deleted all files in /var/opt/samba/lock (brlock.tdb       connections.tdb 
>> messages.tdb     ntdrivers.tdb    ntprinters.tdb   share_info.tdb 
>>unexpected.tdb browse.dat       locking.tdb      ntforms.tdb printing.tdb 
>>) and restarted samba. This time it worked fine.
>>Is there som information about the tdb file and the inner structures of 
>>Samba? What do we lose if we delete the diffrent tdb files?
>>We are using Samba 2.2.2
>This was one of the problems we fixed after 2.2.2. I would
>recommend upgrading to 2.2.5. However there are still some
>scaling problems with Solaris, we are awaiting confirmation
>of a Sun hotfix on the issue (it's a Solaris bug now, not
>a Samba one).
Could you provide some details the bug in Solaris? 2.2.2 used to work 
fine for me, but recently it has fallen apart. 2.2.5 behaves the same. I 
can think of a recent jumbo patch cluster installation that might be to 
blame, but I'd like to know if it's possible to track it down a back it 
out for now.


More information about the samba-technical mailing list