CIFS woes (fwd)

Urban Widmark urban at
Thu Oct 31 18:50:31 GMT 2002

On Wed, 30 Oct 2002, Paul D. Robertson wrote:

> the local machine as a CIFS filesystem.  Here's my issue- I can't execute 
> a binary file if it's on the share.  Doesn't mater if it's ELF or a.out 
> format, or if it's static or dynamic.  
> Scripts run just fine, but binaries give me:  "-bash: ./command: cannot 
> execute binary file" along with "modprobe: modprobe: Can't locate module 
> binfmt-464c" in syslog (which means the binformat isn't recognized 
> AFAICT- noramlly an architecture or endian mismatch?)

"binfmt-464c is ELF -- it means your kernel came across an ELF
 executable and was unable to execute it so it tried to load the ELF
 binary format module. Since you have ELF compiled into your kernel
 already, this didn't work."

> I've tried compiling an executable on the CIFS filesystem, same results, 
> moving the binary to a local filesystem works just fine, but once it's 
> copied back, it won't execute, so it's not the contents of the file.

AFAIK, ELF requires that the filesystem implements mmap in some form so
you are probably using a version that doesn't. For a.out, I think it
depends on the a.out type. Some are demand pageable, others are not.

> Any ideas/pointers/clues would be most helpful at this point.

You could try:


More information about the samba-technical mailing list