CIFS woes (fwd)

Paul D. Robertson proberts at
Thu Oct 31 02:07:01 GMT 2002


(If this isn't the right venue, can someone please cluebat me off-list and 
point me to the right place?)

I need to set up a server that allows chmod/chown stuff, so I'm using the 
CIFS code.  I've got a server set up using Samba 2.2.5, and it mounts from 
the local machine as a CIFS filesystem.  Here's my issue- I can't execute 
a binary file if it's on the share.  Doesn't mater if it's ELF or a.out 
format, or if it's static or dynamic.  

Scripts run just fine, but binaries give me:  "-bash: ./command: cannot 
execute binary file" along with "modprobe: modprobe: Can't locate module 
binfmt-464c" in syslog (which means the binformat isn't recognized 
AFAICT- noramlly an architecture or endian mismatch?)

I've tried compiling an executable on the CIFS filesystem, same results, 
moving the binary to a local filesystem works just fine, but once it's 
copied back, it won't execute, so it's not the contents of the file.

"file" on the dynamic ELF shows:

command: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), 
dynamically linked (uses shared libs), not stripped

I've tried calling the files with ./command as well as through the loader 
with the filename as a parameter- same results either way.

MD5 sums of the binary show identical if on the share or if on a local 

System is Linux, x86 with kernel 2.4.19 and the latest cifs client stuff 
as of a week or so ago.  Server and client are running on the same system 
during testing, and the base system is RH8 other than the kernel with all 
the UTF8 fun that entails.

Any ideas/pointers/clues would be most helpful at this point.


Paul D. Robertson      "My statements in this message are personal opinions
proberts at      which may have no basis whatsoever in fact."

More information about the samba-technical mailing list