Trying to join a Solaris 8 box to Windows 2000 AD.

Clive.Elsum at Clive.Elsum at
Wed Nov 13 22:21:02 GMT 2002

Sorry Andrew, I may have mislead you here. In the pre CVS version I tried
timegm would not compile under Solaris without changing timegm to mktime in
ldap.c. With the newer CVS version I have not made any mods to ldap.c (as
you stated earlier this was a bug that was fixed) and all compiled OK with
mods to the 
Configure commands as detailed earlier.
With the new CVS code unmodified timegm I get the Clock Skew problem. 
You say I have a 10+ hour problem, but where and how, and how can this be

Clive Elsum BAppSc, RHCE
Systems Engineer - Information Technology Group
CSIRO Atmospheric Research
PMB 1, Aspendale, Victoria, Australia  3195
Phone : (+61 3) 9239 4509
Fax:    (+61 3) 9239 4444
E-mail Clive.Elsum at

-----Original Message-----
From: Andrew Bartlett [mailto:abartlet at] 
Sent: Thursday, 14 November 2002 9:03 AM
To: Clive.Elsum at
Cc: samba-technical at; abartlet at
Subject: RE: Trying to join a Solaris 8 box to Windows 2000 AD.

On Thu, 2002-11-14 at 08:23, Clive.Elsum at wrote:
> I can still not get net ads working with Solaris 8.
> With the new CVS code and the mod to timegm in ldap.c The ned ads command
> now fails with Clock Skew, Preauthentication failed, invalid credentials

Well, if you modified that function, then you probably now have a +10
hour problem in the time.  Samba uses the time the ldap server sends to
avoid time skew problems, hence having those timegm() functions in the
first place...  

Andrew Bartlett

Andrew Bartlett                                 abartlet at
Manager, Authentication Subsystems, Samba Team  abartlet at
Student Network Administrator, Hawker College   abartlet at

More information about the samba-technical mailing list