Profile creation

Nathaniel N.Petersen (CNS Student Support) cthulu at
Thu May 30 16:43:02 GMT 2002

ERROR(S): Profile Creation

I have recently been assigned to create a Samba PDC.  Earlier in the 
week, I thought I was successful.  I was able to log in, load (or create) 
the test user's .ntprofile, etc.  Went home that night, happy as could be.
Came back the next day - and nothing was working correctly.  The systems 
could not find the domain.  The domain was not reporting any errors in the 
logs (including, and most importantly, log.nmbd and log.smbd).  

I reported this to my supervisor, and he asked what version of Samba I
was using.  I told him version 2.2.3a.  Well, he says that I shouldn't
use an "alpha" version of Samba.  So I nuke samba off the system (after
making backups of smb.conf and other vital files).  So I download and
compile from the source.  I included the needed "--with" options in
Configure.  Came back after a cup of coffee to test the install.

Here is were things get bad.  I set up my smb.conf file, recreate my
smbpasswd, etc.  I start to add computers using the "blind" method.  All
things seem good (was able to add all the computers I wanted).  I was
able to log on using my test account, and my profile was loaded properly
for WinNT4, Win2K, and WinXP.  (Note: this .ntprofile/ was saved back
when things worked fine.)

So as a final test, I back up my .ntprofile/ and then delete it to
simulate the creation for a new user.  I go to log on with the WinNT4
system, and get the error:

"A domain controller for your domain could not be contacted. You have
been logged on using cached account information.  Changes to your
profile since you last logged on may not be availible."

The funny thing is that it creates the profile and lets me use the
system as if it worked fine.  I verified the newly created .ntprofile/
and it is as it should be.  Then, after logging off, I tried logging in
again, and the same error is given.  So I rm -r .ntprofile/ and restore
from the backup.  Same error, but it loads the profile fine (there is a
visible difference between the two, so I can visually verify that the
.ntprofile/ is being loaded correctly.

So I move on the Win2K system.  This one is even worse.  Here is the
error that I receive when I try to log on:

"Your roaming profile is not available.  You are logged on with the locally 
stored profile. Changes to the profile will not be propagated to the server. 
Contact your network administrator.

DETAIL - The system cannot find the path specified."

I THINK it tries to create the profile, but instead I get a folder
called "?" (\242) or .  To make matters worse, it acts perfectly fine from 
the .ntprofile/ backup.  No error, nothing.  It simply can't make the profile.

I have not been able to test with XP (made the mistake of starting this
email from the only system that has XP loaded on it).  However, I am
confident that it will behave in the same manner as Win2K (...minus the
candy collored shell).

I have attached my smb.conf file.  I did not attach my logs because they
are at level 5 and are figgin' huge.  I will mail upon request.

Nathaniel N. Petersen
CNS Computing
University of Northern Iowa


	workgroup = CNS_TESTING
	netbios name = TEST_SMB_SERVER
	client code page = 437
	log level = 5
	hosts allow =

	security = DOMAIN

	os level = 64
	preferred master = yes
	domain master = yes
	local master = no
	encrypt passwords = yes
	domain logons = yes

	logon path = \\student\%u\.ntprofile
	logon drive = Z:
	logon home = \\student\%u
	admin users = root cthulu
	path = /usr/local/samba/lib/netlogon
	writeable = no
	write list = ntadmin
	guest ok = no
	writable = yes

More information about the samba-technical mailing list