XP spoolsv.exe crash with 2.2.4 (not devmode related?)

Steven J Mackenzie sjmac at suespammers.org
Sun May 19 07:46:01 GMT 2002

Is anyone interested in log files from this?

I've installed drivers for an Epson inkjet printer on a Samba server using
the Add Printer Driver Wizard in Windows XP.

I installed the driver to a 2.2.3a server (from a clean Mandrake 8.2
install). I got as far as printing a test page, but things were very slow:
Trying to view properties on the printer generated a lot of traffic between
the client and the server (about a minute of commmunication between the them
before the properties dialogue appeared).

I hoped that 2.2.4 might have a fix for this packet storm, so I upgraded the
samba software to the 2.2.4 rpm that I found in Mandrakes cooker
distribution. After this, selecting properties on the Epson icon will crash
the XP spoolsv service with the message "The instruction at "0x77f610ff"
referenced memory at "0x00148005". The memory could not be "read"."

Samba 2.2.4-2mdk rpm (from Mandrake cooker)
Running on Mandrake Linux 8.2

MS Windows XP Pro

Some of my config settings:
security = user
encrypt passwords = yes
; kernel oplocks reported flakey on Linux?
kernel oplocks = no
; default devmode - tried yes, tried no; either crash spoolsv on XP
default devmode = no
nt acl support = no

write list = @adm
(my user account, sjm, is in the @adm group, and this group has write access
to the printer drivers share).

More information about the samba-technical mailing list