compile samba-2.2.4 on Solaris 7

Tian-xiong Lu tianl at
Tue May 7 17:23:01 GMT 2002

Thanks, Richard for the reply.

Tried with -fPIC instead of -KPIC, it worked. Checked with gcc
manpage, -fPIC is
an option but -KPIC not.

However, still several other warnings:

1. smbd/password.c: In function 'grab_server_mutex':
    smbd/password.c:1198: warning: passing arg 1 of `message_named_mutex'
    `const' from pointer target type.

2. lib.system.c: In function`sys_readdir':
    lib.system.c:331: warning: return from incompatible pointer type

3. In file included from nsswitch/winbind_nss_solaris.c:20:
    nsswitch/winbind_nss_config.h:135: warning: `ZERO_STRUCTP' redefined
    include/smb_macros.h:48: warning: this is the location of the previous

Could someone take a look at these warnings?

----- Original Message -----
From: "Richard Sharpe" <rsharpe at>
To: "Tian-xiong Lu" <tianl at>
Cc: <samba-technical at>
Sent: Tuesday, May 07, 2002 6:18 PM
Subject: Re: compile samba-2.2.4 on Solaris 7

> On Tue, 7 May 2002, Tian-xiong Lu wrote:
> > Hi there,
> >
> > Just tried compling samba-2.2.4 on a Solaris 7 box with two configure
> > --with-libsmbclient  --with-acl-support
> >
> > When compiling I got a warning message like this:
> > In function "sys_readdir"
> > lib/system.c 331 Warning: return from incompatible pointer type.
> >
> > Also, a lot of messages like this:
> > gcc: unrecognized option '-KPIC'
> I think Jerry is fixing this. It is something like -fPIC under gcc, so you
> could try changing the Makefile to reflect that and get back to us.
> Regards
> -----
> Richard Sharpe, rsharpe at, rsharpe at,
> sharpe at

More information about the samba-technical mailing list