Problem compiling latest HEAD-Samba 3.0-alpha15 (with winbind d and pam) on HP-UX - Possible Bug

MCCALL,DON (HP-USA,ex1) don_mccall at
Mon Mar 11 05:59:02 GMT 2002

Hi Andrew,
I submitted bug reports PR#22628 PR#22632 (I submitted 2 because the 1st one
had the wrong diff format...) with the 
changes I need to get Samba Head to compile an build winbind on HPUX
11.x....  This patch adds the changes made to 2.2 into the structure that
3.0 uses.  Let me know if you need anything else.  The aforementioned
reports get the build, etc to work, but I am still struggling with a problem
in the pam_winbind shared library on 3.0 in HPUX 11; At this point, Samba,
and nsswitch work with winbind, but the pam modules are still getting the
syslog error "unable to load module" when the module is
invoked, leading me to suspect that we are dynamically requiring a load of
some library that is not universally available on HPUX in this version, or
some other issue...- I'll let you know when I have this knocked out...  (or
come begging for help - one or the other!)
Thanks for you attention,


-----Original Message-----
From: Andrew Bartlett [mailto:abartlet at]
Sent: Saturday, March 09, 2002 5:56 PM
To: samba at
Cc: samba-technical at
Subject: Re: Problem compiling latest HEAD-Samba 3.0-alpha15 (with
winbindd and pam) on HP-UX - Possible Bug

Mike wrote:
> I applied all the changes that Don e-mailed to the samba-technical list
(patch dated 3/5). I was able to successfully compile the latest CVS HEAD
source code on HP-UX 11 with winbind and pam. Initially everything looked
good and most of it worked. The problem rose when I tried to login to the
HP-UX server using telnet. I got an error in the system log that it can't
open /usr/lib/security/libpam_winbind.1 which is a copy of
> I am trying to get this working so that I cane use "winbind use default
domain". I
> Could it be that the compiled library is not good? Or could it be that not
all the changes that were applied to samba-2.2.3 to get winbind to work on
HP-UX 11 did not make it to samba-3.0-alpha15.

If changes were made to pam_winbind they could well have been lost.  I
reworked a lot of pam_winbind from examples in Linux-PAM, and I may have
lost somthing in the process.  Could you point me at the changes that
were made and/or provide a suggested patch?

Andrew Bartlett

Andrew Bartlett                                 abartlet at
Manager, Authentication Subsystems, Samba Team  abartlet at
Student Network Administrator, Hawker College   abartlet at

More information about the samba-technical mailing list