Compiling the example VFS modules

Andreas Lund floyd at
Mon Mar 11 05:56:03 GMT 2002

I'm trying to compile the example modules but I keep getting all kinds of
weird errors. First of all, I tried the source RPM from RedHat. I could never
get that to compile at all.

Then I tried the "samba-latest" tarball, and after a few hours of fighting I
got a clean compile. Unfortunately, the .so crashes whenever I try anything
else than pass-through operations.

So I got the latest HEAD from CVS today, and the errors just keep crawling out
of the walls:

# make      
libtool gcc  -I../../source -I../../source/include -I../../source/ubiqx
-I../../source/smbwrapper -Wall -g -c audit.c
mkdir .libs
gcc -I../../source -I../../source/include -I../../source/ubiqx
-I../../source/smbwrapper -Wall -g -c audit.c  -fPIC -DPIC -o .libs/audit.lo
In file included from audit.c:37:
../../source/include/includes.h:392:18: krb5.h: No such file or directory
In file included from audit.c:37:
../../source/include/includes.h:408:27: gssapi/gssapi.h: No such file or
../../source/include/includes.h:414:35: gssapi/gssapi_generic.h: No such file
or directory
make: *** [audit.lo] Error 1

I just compiled and installed Samba itself from this source without any
problems, so I can't understand how includes.h can be full of errors...
Unfortunately, I'm no wizard at C yet so I can't really see what the problem
is either.

It appears to me that there's no clear definition of the interface. I've
counted atleast 5 different prototypes of vfs_init() so far and they all claim

If anyone could point me to a set of files that work, I'd be very happy. I'm
trying to write a module for controlling a media changer but after many many
hours I'm still getting nowhere :-(

Please help? Anyone?

Andreas Lund (floyd at
Tel: +47 / +47
Ano-Tech Computers (
** Never send a human to do a machine's job  **

More information about the samba-technical mailing list