Problem compiling latest HEAD-Samba 3.0-alpha15 (with winbindd and pam) on HP-UX - Possible Bug

Andrew Bartlett abartlet at
Sat Mar 9 15:03:02 GMT 2002

Mike wrote:
> I applied all the changes that Don e-mailed to the samba-technical list (patch dated 3/5). I was able to successfully compile the latest CVS HEAD source code on HP-UX 11 with winbind and pam. Initially everything looked good and most of it worked. The problem rose when I tried to login to the HP-UX server using telnet. I got an error in the system log that it can't open /usr/lib/security/libpam_winbind.1 which is a copy of nsswitch/
> I am trying to get this working so that I cane use "winbind use default domain". I
> Could it be that the compiled library is not good? Or could it be that not all the changes that were applied to samba-2.2.3 to get winbind to work on HP-UX 11 did not make it to samba-3.0-alpha15.

If changes were made to pam_winbind they could well have been lost.  I
reworked a lot of pam_winbind from examples in Linux-PAM, and I may have
lost somthing in the process.  Could you point me at the changes that
were made and/or provide a suggested patch?

Andrew Bartlett

Andrew Bartlett                                 abartlet at
Manager, Authentication Subsystems, Samba Team  abartlet at
Student Network Administrator, Hawker College   abartlet at

More information about the samba-technical mailing list