Spoolss permissions, NT & XP print driver misery (2.2.2/2.2.3a/2.2.4pre)

Homann, Mathias Mathias.Homann at airbus.dasa.de
Wed Mar 6 01:48:11 GMT 2002

Len Laughridge wrote:
> Hello:
> Can someone help me understand the permissions situation with spoolss &
> printer drivers?  Between NT4 & XP, using 2.2.2, 2.2.3a and CVS, I'm in
> printer driver hell....

welcome.... been here for about two weeks now.

> So I thought it was a corrupt driver, blew everything away, and tried to
> re-upload.  Failed miserably every time, no files uploaded to W32X86.
> Upgraded to CVS 2.2.4pre, MUCH worse! With 2.2.4pre you can't even ADD an
> existing printer to the XP workstation without it challenging you for
> stronger credentials!

Here it fails just without any challenge at all, but I'm NOT using any
windows box to upload drivers, because my current task is to find a way
to automate printer driver installation for some 20-odd samba servers
which have some 70-odd printers each, so 'pointy-clicky-gui-drooling' is
totally out of the question for me... ^^

> So, I reverted to 2.2.2...
> Now the XP drivers sort-of work (had to re-upload everything). XP drivers
> ONLY can be uploaded from XP, (not surprising), and while I can print
> landscape now, no other settings will stick (e.g. under Properties/Advanced I
> try to set it to 'Print directly to the printer' but it won't stay that way.)

Yea, with ANY version I've tried so far it filed with totally different
symptoms.. with 2.2.2 at least you could manage some 5-odd printers, but
as soon as I tell my samba about those 70 printers it has to cope with,

but the real pain is, as soon as I move the thing from my text box
(intel linux) to the production-test box (HP-UX 11.00) even 2.2.2 won't
handle a single printer anymore, no matter which samba version. It
horribly fails to translate unicode to ascii on a big-endian machine,
but ONLY for arrays of unicode strings, single strings as in 'printer
driver name' etc work fine. only the list of files which actually ARE
the driver in question get scratched...

another funny fact I've found so far:
when uploading drivers to a samba 2.2.2 box, the connection is made as
'root' (or at least as the user whose credentials you used t authorize
with the server). As soon as you upgrade to 2.2.3a, the location
print$\W32X86 has to be writeable by the guest user!!!! because no
matter which credentials you use, de actual driver installation after
uploading files runs as 'guest'...

seems to me that this spoolss stuff is FAR from beta!


More information about the samba-technical mailing list