Problem compiling Samba 3.0 (with winbindd) on HP-UX

MCCALL,DON (HP-USA,ex1) don_mccall at
Mon Mar 4 13:59:03 GMT 2002

Hi Mike,
Problem is that at 3.0, the team added a 'real' test to verify that a shared
library can be built on the target os, and if not, then the Makefile is
created without the appropriate stuff to build nsswitch/libnss_winbind,
Problem is that this test assumes that the you can build a shared library by
going THRU the cc compiler, giving the appropriate loader flags to be passed
on into the ld program.  On HP-UX's ansi c compiler, thats a bad assumption,
so the test fails, because configure doesn't call the 'ld' program directly
with the shared library flags.
I'm looking into how we could change configure and to take this
into account for HP-UX, but in the meantime, you can work around this by
editing your config.cache and changing the line:
and rerunning configure.

You will know it worked by checking your Makefile for the following lines:

WINBIND_LPROGS = nsswitch/

I found a couple of other problems that we resolved at 2.2.3a that haven't
apparently made it to head yet:

in nsswitch/winbind_nss_solaris.c
REMOVE the following line:
#include <syslog/syslog.h>

in nsswitch/pam_winbind.h
change the following line from:
#if defined(SUNOS5) || defined(SUNOS4) 
#if defined(SUNOS5) || defined(SUNOS4) || defined(HPUX)

I haven't actually verified head and winbind on HPUX 11 yet, but this should
get you past the configure/make issues....

Good luck,

-----Original Message-----
From: Mike [mailto:samba at]
Sent: Sunday, March 03, 2002 1:37 AM
Subject: RE: Problem compiling Samba 3.0 on HP-UX

Hi Don,

This seemed to stop the make error. Something is still missing or not
working with winbbindd on HPUX ARE in the latest SAMBA 3.0 cvs. Did it
work for you?

I ran configure using the custom script you sent me long time ago, then
ran make and then make install. It seems that all the binaries were
created and I was able to execute them. The only think that looks that
is missing is the "" and "". The two
files were not in the source/nsswitch directory or any where else.

I am attaching the configure script and the logs from configure and
make. Please let me know if you know what is the problem or the fix.



-----Original Message-----
From: MCCALL,DON (HP-USA,ex1) [mailto:don_mccall at]
Sent: Thursday, February 28, 2002 5:54 PM
To: 'samba at'; MCCALL,DON (HP-USA,ex1)
Subject: RE: Problem compiling Samba 3.0 on HP-UX

Hi Mike,
problem appears to be that Makefile is using the environment variable AR
tell where the (ar) command is, and the AR variable is not set;
Until I figure out why, you can workaround this by doing the following
before running make:

export AR=/usr/bin/ar

Let me know how it comes out,
-----Original Message-----
From: Mike [mailto:samba at]
Sent: Thursday, February 28, 2002 11:20 AM
Subject: Problem compiling Samba 3.0 on HP-UX

Hi Don,

I am trying to compile Samba Version 3.0-alpha15 on HP-UX 11 since I was
told that the latest HEAD have 'winbind use default domain' feature.
Which will allow users to login without specifying domain name.

The configuration step was fine, when I ran make I got the following
error. I appreciate it if you can help me with error and did the changes
that put in samba-2.3 to make winbind and PAM work with Hp-UX 11 are in
3.0? I just want to make sure that Samba 3.0 and winbind will work with
HP-UX 11.



The error:
Compiling ubiqx/debugparse.c with +z
cpp: "/usr/include/sys/xti.h", line 488: warning 2001: Redefinition of
macro TCP
cpp: "/usr/include/sys/xti.h", line 489: warning 2001: Redefinition of
macro TCP
Linking libsmbclient non-shared library bin/libsmbclient.a
         -rc bin/libsmbclient.a libsmb/libsmbclient.po lib/charcnv.po
po lib/fault.po  lib/getsmbpass.po lib/interface.po lib/md4.po
o lib/pidfile.po lib/replace.po  lib/signal.po lib/system.po lib/time.po
c.po lib/genrand.po lib/username.po  lib/util_getent.po lib/util_pw.po
s.po lib/smbrun.po  lib/bitmap.po lib/crc32.po lib/snprintf.po
lib/dprintf.po  l
ib/xfile.po lib/wins_srv.po  lib/util_str.po lib/util_sid.po
 lib/util_file.po  lib/util.po lib/util_sock.po lib/util_sec.po
smbd/ssl.po  lib
/talloc.po lib/hash.po lib/substitute.po lib/fsusage.po
lib/ms_fnmatch.po lib/s
elect.po lib/error.po lib/messages.po  lib/tallocmsg.po
lib/dmallocmsg.po  lib/m
d5.po lib/hmacmd5.po lib/iconv.po lib/smbpasswd.po
nsswitch/wb_client.po nsswit
ch/wb_common.po  lib/pam_errors.po intl/lang_tdb.po lib/account_pol.po
po tdb/spinlock.po tdb/tdbutil.po   libsmb/clientgen.po
libsmb/cliconnect.po lib
smb/clifile.po  libsmb/clikrb5.po libsmb/clispnego.po libsmb/asn1.po
rap.po libsmb/clierror.po libsmb/climessage.po  libsmb/clireadwrite.po
ilist.po libsmb/cliprint.po  libsmb/clitrans.po libsmb/clisecdesc.po
gram.po  libsmb/namequery.po libsmb/nmblib.po libsmb/clistr.po
libsmb/smbdes.po libsmb/smbencrypt.po  libsmb/smberr.po
libsmb/credentials.po li
bsmb/pwd_cache.po  libsmb/clioplock.po libsmb/errormap.po
libsmb/clirap2.po  lib
smb/passchange.po libsmb/unexpected.po rpc_parse/parse_prs.po
c.po  rpc_parse/parse_misc.po  libads/ldap.po libads/ldap_printer.po
.po  libads/krb5_setpw.po libads/kerberos.po  libads/ads_struct.po
atus.po passdb/secrets.po  libads/util.po param/loadparm.po
param/params.po dync
onfig.po ubiqx/ubi_BinTree.po ubiqx/ubi_Cache.po ubiqx/ubi_SplayTree.po
bi_dLinkList.po ubiqx/ubi_sLinkList.po ubiqx/debugparse.po 
Make: Cannot load -rc.  Stop.
*** Error exit code 1 (ignored)

More information about the samba-technical mailing list