samba 2.2.1a on redhat 7.1 read_socket_data errors

Eric Anderson eanderson at
Mon Jan 28 11:08:12 GMT 2002

I have a problem setting up samba in a mixed win 95,Me,2000 Pro env.


The env was win2000pro serving a handful of shares to windows clients 
(itself, win95 and winMe). An old DOS-based application is on one of the 
shares and is the only critical thing that is needing to be accessed 
reliably. The win2000pro machine has proved to be unstable, and is no 
longer fulfilling the requirements it was purchased to fulfill.

Steps Followed:

Set up a samba server using redhat 7.2 rpm's from redhat on redhat 7.1 
on a box acting as a domain logon server for a handful of users. 
Mirrored the box (fdisk and tar) to another harddrive, and customized 
for the env above. Users, shares, login scripts, etc. Set up the box, 
copied the data over to the samba server from the 2000 pro machine 
(after setting it up on the domain... which worked beautifully... lots 
of thanks to the developers on the win2000 support in 2.2).


Everyone (12 pc's running win95, winMe, win2000pro) can:
   1. log on
   2. execute logon script automatically
   3. access 4 shared folders, retrieve documents, run windows 
applications, DOS-based applications, etc.
   4. upload/save updates to the shares.
   5. copy all files from the share in question to their local machine 
(no access denied errors, or anything unusual).
   6. copy all files from above back to a different folder on the share 
in question.

The problem comes in when users attempt to run the DOS-based application 
located on that shared folder from the machines on the network. I have 
limited it to the following:

1. the Windows 2000 pro machine has no problems accessing and running 
the program.
2. one Windows Me machine has no isssues accessing and running the program.
3. two Windows Me machines have been able to access and run the program 
at some point, but not reliably.
4. the remainder of the win95/winMe machines have not been able to run 
the program, and often lock up when simply attempting to to a 
right-click -> properties on the executable for the program.

The only thing in common between the machines that have problems running 
the program is that in the machine-specific logs i get:

read_socket_data: ... connection reset by peer

I have seen in some of my research that i am not the only person that 
has had this issue, but i haven't found a good resolution yet. I am 
still going through the technical mail list archives though. I am in the 
process of testing the physical network and hub at the moment, but i 
have nothing really to go on... and i am thoroughly confused as to why 2 
machines work smooth as glass, and the other 10 are having serious 
issues on this one service. It is not a logon script or user name issue 
because we have tried the different logon names on other machines with 
no benefit. we have tried uninstalling the network card in one winMe 
machine and completely reinstalled drivers and everything for it... 
nothing changed. We have done profile changes and different things 
(which shouldn't affect a DOS-based program)... and nothing changed.

Any suggestions would be greatly appreciated... and i will be forever in 
your debt.

Eric Anderson
System/Security Administrator
21st Century Electronics

More information about the samba-technical mailing list