ld.so.1: ls: fatal: relocation error: file /lib/nss_winbind.s o.1: symbol socket: referenced symbol not found

Tim Potter tpot at samba.org
Thu Feb 21 12:51:17 GMT 2002

On Thu, Feb 21, 2002 at 02:22:22PM -0500, Thomas, Daniel J. wrote:

> If I do an "ls -l" on a PC file in my samba share from the Unix end, now
> rather then giving an error, I get the following:
> # pwd
> /apps/temp                            << This is my samba share
> # ls -l
> total 0
> After show "total 0" the system just hangs there.  I did a tail on the
> system log and on /usr/local/samba/var/log.winbind
> Neither had any errors till I did "Control + C" to stop it.  The output in
> the log.winbindd file is always the same:

It sounds like you have solved the linking problem.  This problem is a
different one.  (-:

> After I made this change, I did a "make uninstall"  and a "make clean".
> Then I ran "make" and "make install" again.

Did you copy the freshly compiled libnss_winbind.so in to /lib again?


More information about the samba-technical mailing list