msdfs, win98 / NT and non-resolvable symlink paths

Johan Coenen johan.coenen at
Thu Feb 14 08:22:19 GMT 2002


Tried "case sensitive = No" as well as "case sensitive = Yes"
I get the same error in both cases.


At 09:55 14/02/2002 -0600, Esh, Andrew wrote: 

If you'll allow me to do some guesswork ... 

It looks like the same problem is being addressed in the samba-technical
thread "Re: WIN98 Can't access some directories - ???", and the solution
there seems to be the smb.conf setting "case sensitive = No".

I wonder why this is specific to msdfs links? Maybe the link resolution
code assumes case insensitivity, and upcases the link name for comparison?
Maybe MS is changing the case in some of its references in the network
requests? Here are some interesting log entries posted by Arjen van Drie:

(First the link is lower case) ... 
[2002/01/30 11:12:59, 5] msdfs/msdfs.c:is_msdfs_link(185) 
  is_msdfs_link: /home/samba/dfsroot-aiv/pcsupport -> 

(now it's upper case) ... 
[2002/01/30 11:12:59, 4] msdfs/msdfs.c:resolve_dfs_path(257) 
  resolve_dfs_path: Redirecting \LS-AIV-03\SHARED-AIV\PCSUPPORT\* 
parent /home/samba/dfsroot-aiv/pcsupport is dfs link 
[2002/01/30 11:12:59, 3] msdfs/msdfs.c:dfs_redirect(309) 
  dfs_redirect: Redirecting \LS-AIV-03\SHARED-AIV\PCSUPPORT\* 

(and the error) 
[2002/01/30 11:12:59, 3] smbd/error.c:error_packet(99) 
  error string = No such file or directory 

Maybe the name comparison is failing because the case doesn't match. 

I am not convinced that turning off case checking is the real fix. Some
users may need to leave case sensitivity turned on. That should not cost
them the ability to use msdfs links.

It's a good data point though. 

-----Original Message----- 
From: Gerald Carter [<mailto:jerry at>mailto:jerry at] 
Sent: Thursday, February 14, 2002 8:11 AM 
To: Arjen van Drie 
Cc: samba-technical at; johan.coenen at 
Subject: Re: msdfs, win98 / NT and non-resolvable symlink paths 

On 14 Feb 2002, Arjen van Drie wrote: 

> Problem exists with Samba 2.2.2 and 2.2.3a. Tested on RedHat Linux 7.1 
> == Problem. == 
> Where Windows2000 clients do, win98 and NT clients do not follow a msdfs 
> link. When we open Windows Eplorer, doubleclick on a mounted SMB network 
> share and click on one of the maps therein on the _left_ side of Windows 
> Explorer, the right side shows up empty. There are files though. From 
> then on, no matter what route we take to get to the share, the files 
> remain invisible. 

We need to figure out why it works for me and why not for you. 
Shirish?  Any ideas? 

 "Sam's Teach Yourself Samba in 24 Hours" 2ed.      ISBN 0-672-32269-2 
 --"I never saved anything for the swim back." Ethan Hawk in Gattaca-- 


More information about the samba-technical mailing list