pdbedit segfaults in SAMBA_3_0

Bradley W. Langhorst brad at langhorst.com
Tue Dec 17 03:22:01 GMT 2002

it has not changed from alpha21 
(which also segfaulted)
a20 did not segfault

i'm compiling with --with-ldapsam and --with-tdbsam
tried both with and without steve's latest debian patches.

as noted in the last check in (a month ago)

        Removed global_myworkgroup, global_myname, global_myscope. Added
        liberal dashes of const. This is a rather large check-in, some
        things may break. It does compile though :-).
pdbedit -h shows help normally
pdbedit -l segfaults
pdbedit -b (tried all combinations of ldap ldapsam unix unixsam tdb tdbsam all segfault)

here's my entire ./configure line
in case you're interested
--with-fhs \
                --prefix=/usr \
                --sysconfdir=/etc \
                --libdir=/etc/samba \
                --with-privatedir=/etc/samba \
                --localstatedir=/var \
                --with-netatalk \
                --with-smbmount \
                --with-pam \
                --with-syslog \
                --with-sambabook \
                --with-utmp \
                --with-readline \
                --with-pam_smbpass \
                --with-libsmbclient \
                --with-winbind \
                --with-msdfs \
                --with-automount \
                --with-acl-support \
                --with-tdbsam \

I can compile a20 with a similar ./configure and don't see the pdbedit segfault


Bradley W. Langhorst <brad at langhorst.com>

More information about the samba-technical mailing list