Very bad performance when copying large files from windows to samba-share

Lars Heineken Lars.Heineken at
Fri Apr 12 06:36:01 GMT 2002

Hi !

I'm searching for an answer to this problem for a while, maybe this is the right place for help ?

I share my drives with samba, (smb.conf is nearly unchanged from default). Lately my brother tried to move a 780MB file onto one of my shares. As samba is working fine with all other files, I thought everything would work fine. 

It didn't.

So here's the problem:
No Windows-client can copy files larger than about 700MB onto one of my shares. The moment the transfer starts, no popup-window appears on the windows-screen, but my disk begins heavy writing, even no single packet is floating through the network. After about 30seconds the connection times out. The copied file can be found on my share but it's empty.
The logs say something about oplocks, but as I turned them off for a test nothing changed.
When my brother maps the drive and copies the file inside the DOS-box, everything is fine.
It seems that the win98 explorer has some kind of bug, that tells him to set up an empty file before he starts writing.

As there must be a way to copy large files from windows to a samba-share, I'm seeking someone who has solved this problem.


Lars Heineken.

PS: I read the man page about smb.conf and all switches that could have an effect are set up correctly by default. Running version is 2.2.3a-10mdk.

More information about the samba-technical mailing list