Strange Samba 2.2.0/NAT Difficulty

Mark Corner mcorner at
Mon Sep 10 07:56:10 GMT 2001

Everything was working fine, but now I am stumped.

I am attempting to mount a share to a Win2k client at home from a Linux
2.4/Debian machine at school.  The Samba server is version 2.2.0 and I
have tried it from Win2k Sp1 and Sp2 clients.  Basically it says it cannot
find the machine (I have tried network names, IP address etc).  It is
running through a D-Link cable "router" into the Road Runner cable modem

That is what doesn't work, however, this is what DOES work:

Mounting the samba share at work from anything at work (Win2k, Linux,
Win2k behind a Linux NAT)

Mounting windows shares at work from clients at home using Win2k. (forgot
to try Linux)

I tried a tcpdump on my Linux Samba box.  I get a few requests on the
magical port 445, but no response from the samba server.

This is my only guess: The D-Link "router" is mangling the NAT just enough
to confuse samba but not windows.  Seems unlikely doesn't it?

Other things to try?  Nothing at all shows up in the nmb and smb logs.

I can give you other details if you need them.  I am using simple
workgroups, no PDCs or anything wacky.

Thank you for any advice you have.

Mark Corner
mcorner at

More information about the samba-technical mailing list