Samba 2.2.2 as PDC and groups don't work

Tobias Burnus tobias.burnus at
Thu Nov 22 11:11:02 GMT 2001


On Thu, 22 Nov 2001, Bolke de Bruin wrote:
> This is currently not implemented.
I probably wasn't clear enough (which come that I'm not a windows
expert); I ment that
  domain admin group = @system
doesn't seem to work (@system = gid=0) and it worked once (2.2.1a)
(see email below)

> Work is underway though.
Looking forward for this feature as well (sharing unix and windows


> -----Oorspronkelijk bericht-----
> Van: samba-technical-admin at
> [mailto:samba-technical-admin at]Namens Tobias Burnus
> Verzonden: donderdag 22 november 2001 14:20
> Aan: samba-technical at
> CC: Tobias Burnus
> Onderwerp: Samba 2.2.2 as PDC and groups don't work
> Hi
> we use Samba 2.2.2 and have discovered that we don't get the group
> information correctly. The primary group is ok (tells the usermanager)
> but the user is only in the group "users". All unix-groups appear to be
> present (but empty; this might actually a security feature).
> It definitly worked with Samba post-2.2.1a (CVS-2001-06-28; and W2k/DE).
> We tried it on Windows 2001 (German) and Windows XP (German) with several
> accounts (also with the root account needed to for adding Win2k to a
> domain) but it doesn't work
> The server runs Tru64 Unix.
> I didn't find something odd in the logs, but I don't know for what I need
> to look for.
> With warm regards and thanks for any pointer,
> Tobias

More information about the samba-technical mailing list