problem browsing Printers share on Samba 2.2.0 server from NT4 - REPOST

Paul Sanders sanders_p at
Thu May 17 14:49:45 GMT 2001

Hello all!

I am still experiencing this problem.  Has any one else seen this or something
like it?
I failed to mention in the first post that all printing functions appear to
work:  I can use the NT APW to setup a printer and it will print (i didn't try
all 82 printers - just a few but they all worked fine...). 

I have also tried rpcclient to add the drivers as per section 4.2.3 of the new
SAMBA project doc and i get a "failed session setup". 

Is this a timeout issue and if so what should i do to correct it?

Thanks in advance...


I am experiencing a problem that just started last week.  When I connect from
to samba [as Nt user mapped to root] I get the normal share listing of
tmp, root, and the Printers folder.  This comes up within 1-2 seconds.  The
problem is that when I open the Printers folder to display the samba shared
printers [in order to select them and add/change drivers...] I get a blank
window and an hourglass for >5 minutes then I get either a window with only
Add Printer icon [no printers] or explorer chokes and i get a Dr. Watson error.

This is using the same smb.conf I have used on perhaps 20-30 builds during
testing - I have never seen this error before.

Does this ring a bell with anyone?  I have included my smb.conf below and
attached an L10 log for the machine I'm connecting from. BTW, this happens
both NT and w2k.

as usual, any input is appreciated.

The setup:

Samba 2.2.0 - CVS this morning
Va Enhanced RHL 6.2.4
VA 1220 server

smb.conf snippet:
	printcap name = /etc/printcap
	log file = /usr/local/samba/var/log.%m
	max log size = 50
	domain master = no 
	dns proxy = no
	password server = hcpnt013 hcpnt014
	printing = bsd
	encrypt passwords = yes
	preferred master = no
	server string = Red Hat Linux 6.2.4 - Samba 2.2.0
	workgroup = UHCWNY
	protocol = NT1
	netbios name = hcplnx00
	socket options = TCP_NODELAY 
	local master = no
	load printers = yes
	client code page = 437
	security = domain
	wins server =
	os level = 0
	username map = /usr/local/samba/lib/
	debug level = 10

	comment = Home Directories
	browseable = no
	writable = yes

	comment = All Printers
	path = /var/spool/samba
	print ok = yes
	guest ok = yes

	path = /tmp
	writable = yes
	comment = Temporary file space
	public = yes

	guest ok = yes
	browseable = yes
	read only = yes
	comment = printer drivers
	path = /usr/local/samba/printers
	write list = root

	printable = yes
	comment = HP LaserJet 4000 Series PS
	printer = npcl101
	writable = yes
	path = /var/spool/lpd/npcl101
	public = yes

{plus 81 more printers - only difference is model in comment and printer/spool
dir name...}

-------------- next part --------------
A non-text attachment was scrubbed...
Name: log.bd000973
Type: application/octet-stream
Size: 18784 bytes
Desc: not available
Url :

More information about the samba-technical mailing list