printing, locking, etc in 2.2.0

Dmitry Melekhov dm at
Fri May 11 03:41:56 GMT 2001


I moved one of our file server  (with not too much users) to 2.2.0 from
2.0.7 to test
2.2.0 stability. What I really need is PDC functionality, but I don't
test it now, because
I want to be shure that 2.2.0 is stable enough as file and print server.

I have several problems and posted problem description in
samba at, but have no replies.
btw, I use RH 6.2.

1. NT printing

   I use samba with lprng, 2.0.7 with lprng is very stable and fast,
2.2.0 too, but only as lanmanager.
   When I try to print from w2k or NT I have following problems:
   a) selecting of printer or shoing properties is too slow, really too
slow! It takes about minute to open
 printer properties page! And, when this page is opens smbd eats about
90% of cpu on p3-800 server.
When printer properties page is opened smbd eats about 50% of cpu! This
make Samba not usable for
print serving more that 1-2 clients. Until code stabilization I want to
know is there any way to turn off
NT printing for nt/w2k clients?
  b) sometimes printer drivers dissapear. Yes, they exists, but nt/w2k
clients show NO DRIVER. I don't know
what to do. I have 6 printers connected to print server and reinstalling
driver is not easy task because of
previous problem

2. Locking

  When user _correctly_ log off, or client crash locks still remains:

 Samba version 2.2.0
Service      uid      gid      pid     machine
print$       dm       dm       23513   dm-w2k   ( Thu May

10 19:24:47 2001
dit          dryahlov dit      12394   dryahlov ( Thu May
10 19:09:40 2001
common       ansi     common   10305   anastasia ( Thu May

10 19:06:00 2001
msoffice20   musihina msoffice 23129   tanya    ( Thu May
10 18:52:57 2001
common       dryahlov common   12394   dryahlov ( Thu May
10 19:09:41 2001
IPC$         dm       dm       23513   dm-w2k   ( Thu May

10 19:23:28 2001

Locked files:
Pid    DenyMode   R/W        Oplock           Name
/usr/print/WIN40/hpbfab.ddu   Thu May 10 18:45:59 2001

As you see there is no such pid- 5346 , but lock is still exists! This
make samba unusable for
file server applications!

3. lib/util_sock.c:write_socket_data(542)

My log.smbd is full of such messages. I see in log with debug level 10

[2001/05/10 09:02:25, 3] smbd/sec_ctx.c:set_sec_ctx(310)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2001/05/10 09:02:25, 5] smbd/uid.c:unbecome_user(217)
  unbecome_user now uid=(0,0) gid=(0,0)
[2001/05/10 09:02:25, 6] param/loadparm.c:lp_file_list_changed(2144)
  file /etc/samba/smb.conf -> /etc/samba/smb.conf  last mod_time: Thu
May 10 08:33:09 2001

[2001/05/10 09:02:25, 0] lib/util_sock.c:write_socket_data(542)
  write_socket_data: write failure. Error = Broken pipe

All works OK, no problems with clients, but, anyway, something is wrong

4. winbind

   I set debug level = 10 and see that samba always try to get sids from

 [2001/05/10 08:31:48, 10] smbd/uid.c:gid_to_sid(409)
  gid_to_sid: winbind lookup for gid 5284 failed - trying local.

 I don't produce this perfrmance penalty or not, but I think that yes.

I want  to know are this problems solved in currents CVS or will be
solved in 2.2.1?

Wire connection and Windows reinstallation senior engineer
Dmitry Melekhov
2:5050/11.23 at fidonet

More information about the samba-technical mailing list