Sharing a directory with samba mounted shares (2.0.x): files invisible

Martin Vonwald martin at
Thu May 10 12:01:50 GMT 2001

Hi all!

I have the following situation. One machine (gateway) is mounting (smbclient 
2.0.9) some samba shares (2.0.x) over a slow and secure connection. The 
directory where those shares are mounted is then shared (2.0.9) to some 
Windows and Linux machines in the local network. (This setup can not be 
When I copy now e.g. 10 small files from a workstation to one of the remote 
directories usually some files are invisible: I cant see them in the 
directory listing, but I can read them. When I now delete one of the visible 
file all the invisible files appear.
When I do the same directly on the gateway I dont have this problem. I tried 
to solve this problem now for weeks without any success; I also tried to post 
it to comp.protocols.smb but with no response.
I tried varies settings to dis/en-able (getwd cache, strict sync, sync 
always, oplocks, ...) without success.

Can anybody give me any direction to look for a solution - I'm pretty 
desperate :-(

I attached (partly) the smb.conf of the gateway and my little bash script for 

Thanks in advance for any comments/suggestions/ideas/guesses!

P.S: Something similar: When a file is renamed it disappears for a blink of 
an eye and then reappears - maybe that is related......

--------- smb.conf (gateway) ------------
   workgroup = XXXXXXXX
   netbios name = XXXXXX
   guest account = nobody
   keep alive = 30
   os level = 2
   security = user
   status = yes
   encrypt passwords = yes
   socket options = TCP_NODELAY SO_SNDBUF=8192 SO_RCVBUF=8192
   map to guest = Bad User
   client codepage = 850
   character set = ISO8859-1
   browseable = yes
   dos filetimes = yes
   preserve case = yes
   short preserve case = yes
   printing = bsd
   load printers = yes
   getwd cache = yes

   hosts allow = xxxxxxx
   path = /server/extern
   writeable = yes
   force user = samba
   force group = samba
   force create mode = 0770
   force directory mode = 0770
   oplocks = no

------------ testscript --------------
test -d $TESTDIR || mkdir $TESTDIR
for fn in f1 f2 f3 f4 f5 f6 f7 f8 f9 f10
        echo "Hello" >$TESTDIR/$fn
number=`ls $TESTDIR | grep -c f`
if test $number -ne 10
        echo "Transfer failed!"
        sleep 2
        echo "Hello" >$TESTDIR/knubl
        sleep 1
        rm $TESTDIR/knubl
        number=`ls $TESTDIR | grep -c f`
        echo "Now we have $number files."
        echo "Transfer ok."

More information about the samba-technical mailing list