SAMBA_2_2 printer driver problem

John Wilson john_wilson100 at
Mon May 7 23:11:58 GMT 2001

Hi there!

I've just wiped out the company's NT server and installed FreeBSD on it!
I also installed samba-2.2.0, and it works really well -- grand job guys! 
The only problem I have is the printer setup.

First of all, I put the correct entry in /etc/printcap, and then copied the
old directories C:\WINNT\system32\spool\...whatever...\W32X86 and WIN40 to
/usr/local/samba/printers, then put the corresponding entry in smb.conf, as

When I tried to add a printer from a Win2K client, I chose "Browse for
Printer" and then the first weird thing that happened was that for some
reason Windoze listed my printer twice, once under the server name, and then
again as one line with the printer name appended to the server:


When I clicked on "+SERVERNAME", it expanded and *also* showed "printername"
(see below) -- so I had both entries listed, and the second one even
correctly recognised my printer:

 --printername			      PS printer

-SERVERNAME\\SERVERNAME\printername   HP LaserJet 4050 Series PS   PS

When I clicked "Next", Win2K complained that the printer driver installed on
the server is incorrect and offered to install a local printer.   I
cancelled and deleted all the files from W32X86 and WIN40 directories on the
server just to see what happens then, and when I repeated the same, I think
this time Win2K said that there were no printer drivers installed on the
server at all and offered to install locally again.    When I clicked "OK"
to install a local printer, everything worked (so it's not the end of the
world :) but I would still like to work out a solution that would allow me
to install drivers from the server.

I thought it was a Win2k issue and tried the same on WinNT 4, alas with the
same results.    (If it matters, I used Win2K Advanced Server and WinNT 4
Enterprise Edition to add printers - don't have any NT workstations here.)

And before you ask, yes, I made myself a printer admin (printer admin = john
in the [global] section), and changed the permissions on the directories to
make them writable by john, but that didn't change anything.

I even thought that the drivers I used *were* incorrect, but then how come
the same drivers on NT were used to install printers on Win2K clients with
no problems whatsoever?    Could it be that NT is looking for some files and
samba is saying they don't exist because UFS is case-sensitive and NTFS is
not?   Maybe I need to copy some other files from NT?    BTW if any of you
guys have got the same printer (HP LaserJet 4050) working, I would
appreciate if you could send me the files I need.

Heck, I can't even reproduce it anymore ever since I clicked "Yes" to
install a local driver; now Win2K knows that it has got the right driver and
doesn't even try to download from server!

Please tell me what I'm doing wrong.   I'm using the latest CVS (SAMBA_2_2

John Wilson

Send a cool gift with your E-Card

More information about the samba-technical mailing list