libreadline error on samba-common install - code page generation

Roger Thomas roger at
Wed Mar 28 21:22:56 GMT 2001

Okay - I hope I'm asking the right folk, because I can't find anything
about this error on any other site.  I'm trying on install samba ([samba
samba-common samba-client]-2.0.6-9.i386.rpm) on a Red Hat 6.1 machine
using rpm (rpm -ivv samba-common-2.0.6-9.i386.rpm).  When I run this,
the install script runs fine to a point, but ends with a series of
errors that look like this:

/usr/bin/make_smbcodepage c 866 /etc/codepages/src/codepage_def.866
/usr/bin/make_smbcodepage: error in loading shared libraries:
/usr/lib/ undefined symobl: BC

I've read up a little on both make_smbcodepage and shared libraries.
When I run make_smbcodepage from the command line I get the same error,
so it seems the problem is in /usr/lib/  I checked out
the /usr/lib directory and saw the following:

/usr/lib/     -->
/usr/lib/   -->
/usr/lib/ -->

This seems to be the libreadline for this version, but it doesn't seem
to be working.  I tried loading a libreadline from my v.7 system
(, but that didn't work at all.  I'm now wondering if
make_smbcodepage wants the original (whatever that
was), but I can't find where the file would be.  Any hints?

(Yes, I'd like to just upgrade the bloomin' thing to 7.0 as well, but
it's in a server farm in California and I'm in Michigan.)

Any help would be appreciated!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: roger.vcf
Type: text/x-vcard
Size: 277 bytes
Desc: Card for Roger Thomas
Url :

More information about the samba-technical mailing list