[PATCH] Re: Take Ownership

jtrostel at connex.com jtrostel at connex.com
Sat Jun 30 03:52:06 GMT 2001

Applied the patch.  Take Ownership still doesn't work.  I get an error from
rpc_server/srv_samr_nt.c (samr_query_useraliases).  There is nothing in the
function, so it makes some sense that it wouldn't work.  I tried inserting
the function from the HEAD branch... it compiles and loads smbd.... now the
account just can't be found on the 'remote machine', i.e. the linux box and I
no longer can change permissions on the files. (switching back to the 2_2
version of srv_samr_nt.c for now...)

Do I need to try bring more functions over from HEAD?

What functions get called to accomplish this task?

Should I try patching my extended ACL patches into the HEAD branch instead of
the SAMBA_2_2 branch?

On 29-Jun-2001 Jeremy Allison wrote:
> Manoj Naik wrote:
>> I've built a patch that implements the 0x2D LSA RPC
>> (LsaGetConnectedCredentials) used by 'Take Ownership'. Structures
>> modified slightly from TNG code.
>> Manoj.
> Thanks a lot - committed to HEAD and 2.2.
> Jeremy.
> -- 
> --------------------------------------------------------
> Buying an operating system without source is like buying
> a self-assembly Space Shuttle with no instructions.
> --------------------------------------------------------

John M. Trostel
Linux OS Engineer
jtrostel at connex.com

More information about the samba-technical mailing list