Win 2K not joining domain with IRIX binary 2.2.1a...

Kevin (HxPro) Wheatley hxpro at
Mon Jul 23 12:44:29 GMT 2001

"Kevin (HxPro) Wheatley" wrote:
> Using the binary version for IRIX 6.5
> I'm getting api_samr_set_userinfo: Unable to unmarshall
> SAMR_Q_SET_USERINFO errors, when joining the domain, and generally not
> having much joy with it, Tried adding machine account manually with and
> without the '$', restarting the machine each time, root in smbpasswd
> (with a different root password to the real one!) Even restarting PDC
> each time ...
> Any ideas?? is it a bad binary version ??

I compiled up a version myself  and was able to join the domain at first
attempt. Will install my version on the existing PDC, hopefully that
will sort it out.

So it is a red herring ... and for my next red herring ... has anybody
tried compiling any of the VFS modules on IRIX ?? There appears to be a
declaration miss match when compiling ....

hxpro at wallace 141% gmake
/usr/freeware/bin/libtool cc  -I../../source -I../../source/include
-I../../source/ubiqx -I../../source/smbwrapper -O2 -c audit.c
rm -f .libs/audit.lo
cc -I../../source -I../../source/include -I../../source/ubiqx
-I../../source/smbwrapper -O2 -c audit.c  -DPIC -o .libs/audit.lo
cc-1143 cc: ERROR File = audit.c, Line = 110
  Declaration is incompatible with "BOOL vfs_init(connection_struct *)"
          (declared at line 4371 of "../../source/include/proto.h").

  struct vfs_ops *vfs_init(void)

1 error detected in the compilation of "audit.c".

before I go wandering off on a goose chase are they supposed to work ?
Is there something I should know??



| Kevin Wheatley             | These are the opinions of nobody   |
| Technical Services Manager | and are not shared by my employers |
| Cinesite Digital Studios   |                                    |

More information about the samba-technical mailing list