File corruption with 2.2.1a, Tru64 5.1, and Excel under Win98

Jeff Lessem Jeff.Lessem at Colorado.EDU
Tue Jul 31 21:49:21 GMT 2001

Sorry for posting this to technical, but I sent it to the regular
samba list yesterday, and have not received any replies.  If there is
any more information that would make this more palatable for
debugging, let me know and I will provide it as soon as possible:

[This following has been edited from what I originally posted to
reflect what I have done since that time.]

I recently upgraded samba on my Alpha running Tru64 5.1 from 2.0.10 to
2.2.1a.  Everything seemed to work fine, but I am getting a strange
problem with Excel from Office 2000 and Windows 98.  This problem only
seems to occur with Windows 98, as I couldn't reproduce it with
Windows 2000[1].  Another alpha user reported to me that the problem
does not occur with Excel from Office 97, but I do not have 97
installed on any machines, so I can't verify that.

Opening an existing Excel worksheet stored on a share from the server
is fine.  Simply clicking on the floppy disk save icon and then
closing Excel will prevent the file from being opened again.  Excel
fails to open the file with a dialogue box saying "Unable to read
file" (The file can be opened with wordpad).  The .xls file then
appears to be permanently corrupted, as copying it to the desktop does
not allow it to be opened.  The .xls file saved (with no changes) is
the same size as the original file, but it does differ from the
original.  A cmp -l between the broken and original file shows that
many characters are set to 0 in the broken file, while they contain
values in the original file.

The problem doesn't occur with a very basic Excel file containing only
a few numbers in a column, but I can provide a 20k .xls file which
will cause the problem every time.

Falling smbd back to smbd.old makes the problem go away (a broken file
is still broken, but a good file won't be broken by opening and saving
it).  I built samba with Compaq's cc -fast.  I tried again with -O and
-O0 but those had no effect on the problem.  I also tried building
samba on a Tru64 4.0d machine (with cc) and ran the resulting smbd
binary under 5.1, but the problem persists.  I also have the problem
with 2.2.0, 2.2.1a CVS, and HEAD.

I attempted to build samba with gcc 3, but that fails.  I then
attempted to build gcc 2.95.3, but that fails.  If people think a gcc
build is worth pursuing, let me know and I will keep at it.  I also
tried using cc with the -taso (loads addresses into the lower 31-bits,
to avoid 32 bit assumption errors), but that had no effect on the

I am not sure which files would be useful for debugging information
(smb.conf, config.cache, log.smb, etc.).  I turned debug level up, but
nothing out of the ordinary seemed to be reported.  Of course Excel
gives no sort of useful information.  Just let me know what debugging
information would be useful in tracking down this problem and I will
provide it.

[1] Earlier this morning a user reported that Word from Office 2000
under Windows 2000 crashed while saving a file, and then that file
couldn't be opened again.  The temporary file created by Word (and
left behind) could be opened and contained most of the changes which
had been made.  I don't necessarily want to lump this in with the
problem I report above, because in this case Word crashed, while Excel
reports that nothing is wrong.

Jeff Lessem.

More information about the samba-technical mailing list