problem adding shahms ldap patch

Claudia Moroder claudiamoroder at
Mon Jul 30 15:54:55 GMT 2001


I patched my samba 2.2.1a with shahms patch from Fri Jul 20 with patch -p0
<patchfile and the patch worked.

I reinstalled the originale source and tried the Thu Jul 26 patch but now I
get the following errors.

patching file samba-2.2.1a/source/
Hunk #1 FAILED at 1712.
1 out of 1 hunk FAILED -- saving rejects to file
patching file samba-2.2.1a/source/include/smb.h
patching file samba-2.2.1a/source/param/loadparm.c
Hunk #4 FAILED at 771.
Hunk #5 FAILED at 969.
Hunk #6 FAILED at 1311.
Hunk #8 FAILED at 1513.
Hunk #9 FAILED at 1611.
5 out of 9 hunks FAILED -- saving rejects to file
patching file samba-2.2.1a/source/passdb/ldap.c
Hunk #2 FAILED at 21.
Hunk #4 FAILED at 1137.
2 out of 4 hunks FAILED -- saving rejects to file

Is it right to use patch -p0 <patchfile ?
Do I need to start autoconf to have the updated configure file ? ( patch
changes only )

Shahms asked for testers. I would like to test the patches because at the
office we need desperately samba using openldap. What I need is
documentation on what schema to add to openldap and what attributes I must
Is there docu available ?

Bye and thank you for samba.

Andreas Moroder

More information about the samba-technical mailing list