fcntl F_SETLKW64

Romeril, Alan a.romeril at ic.ac.uk
Mon Dec 17 10:18:01 GMT 2001

    Just pulled the cvs and I get this on compile....  Broken LDAP headers?


bash-2.04# make
Using FLAGS =  -O  -I./popt -Iinclude -I./include -I./ubiqx -I./smbwrapper
      FLAGS32 =  -O  -I./popt -Iinclude -I./include -I./ubiqx -I./smbwrapper
      LIBS = -lsec -lgen -lresolv -lsocket -lnsl  -ldl -lldap
      LDFLAGS =
Compiling smbd/server.c
In file included from include/includes.h:387,
                 from smbd/server.c:22:
/usr/include/ldap.h:488: field `ldctl_value' has incomplete type
/usr/include/ldap.h:1077: parse error before `BerElement'
/usr/include/ldap.h:1079: parse error before `BerElement'
/usr/include/ldap.h:1109: parse error before `BerElement'
make: *** [smbd/server.o] Error 1

Jeremy Allison wrote:

> On Mon, Dec 17, 2001 at 11:16:46AM +0000, Romeril, Alan wrote:
> > Hi All,
> >     Just upgraded a pair of servers from 2.0.x to 2.2.2 and while things
> > like profile loading on Win2k clients is fast the one of the machines
> > gets slayed (load average 30 ish) with smbd`s not appearing in smbstatus
> > but calling the following...
> > What`s going on here?
> > Other smbd`s startup and call similar to below then exit and more start
> > and do the same.
> This is a bug that took us a long time to track down, but we think we've
> solved it in the SAMBA_2_2 and HEAD CVS.
> If you can run the SAMBA_2_2 CVS code and test this that would help
> greatly (this has solved the problem for everyone who has used it so
> far).
> Thanks,
>         Jeremy.

More information about the samba-technical mailing list