W2k -> Solaris: Cannot connect to port 139

Conrad Minshall conrad at apple.com
Wed Aug 29 06:48:14 GMT 2001

Perhaps a firewall between you and the server is the trouble?

At 1:18 PM -0700 8/28/01, Michael Kolmodin wrote:
>Excuse a newbie trying to install and use samba. But I have been
>trying hard and eventually reached a point where a contact with
>the technical gurus seem to be the only way. Ignore me, spam me
>or do something worse if I'm wrong...
>In short: I have portable which I move between my office
>and my home. At office, everything is ok. At home, I occasionally
>get samba working. However, after rebooting the PC it invariably
>fails. My home is just a Solaris server and my W2k client, nothing else.
>TCP-IP is ok, so is NMB name lookup according to the official
>Diagnosis.txt tests and my own judgment for what it's worth.
>The problem seems to be that
>I cannot connect to port 139 on the server from the PC with
>'telnet name-of-server 139'. At my office I get a connection to
>working samba servers. At home, I get a connection to all TCP-based
>services besides netbios-ssn/139 which most often fails without any
>trace in the logs. It always fails direct after a PC reboot. When
>it occasionally succeeds, most often after a long wait time, next
>attempt fails.
> From the server, I can connect to 139 w/o any problem (!)
>The problem exists even with a minimal smb.conf less than 10
>lines. Basically I trust it since I now and then have been able
>to mount disks, print etc.
>Have tried version 2.0.7, 2.2.1a and CVS head trunk with same result.
>Client updated to SP2, no change. Solaris 8. And yes, I've
>compiled samba on my machine ;-) Also tried both stand-alone and inetd.
>Is this a bug in samba, Solaris and/or me? I just wonder...
>If anyone has a hint it feels like it would save me from becoming insane.

Conrad Minshall, conrad at apple.com, 408 974-2749
Apple Computer, Mac OS X Core Operating Systems

More information about the samba-technical mailing list