Using the "nis" scripts to add users in Samba

Santomauro, Deborah deborah.santomauro at
Wed Aug 15 15:10:38 GMT 2001


I have been wrestling with this problem for quite a few days now. I'm trying
to add a user - tried first the usual method of SWAT, then smbpasswd, and
both returned errors of "failing to add 'joeuser'". In going back to the
source directory where I first installed Samba, I came across some "nis"
scripts that look like they can be used to add users automatically to the
smbpasswd file.

First I ran  
# niscat passwd.org_dir | ./ >
/usr/local/samba/private/smbpasswd Not found. Not found. Not found. Not found.

Next I tried to run
# ./
can't create table: Permission denied.
Unable to create group "": Permission denied group not found

Question: do these have to run on the master server?

To reiterate (I had mentioned this in previous 'help' emails) I installed
Samba on a Sparc5 running Solaris 2.7 with automount/NFS/NIS+ (master
server, an Enterprise 4000, does not have Samba).

Please can someone tell me what I need to do to get this working? I really
need to get this up and going as soon as possible.


Deborah Santomauro
Unix System Administrator
Lockheed Martin Mission Systems
email: deborah.santomauro at
Work: 303-971-7333
Fax: 303-977-4965
    o,    o__              o_/|   o_.
   </     [\/              [\_|   [\_\
(`-/-------/----')      (`----|-------\-')

-When you come to the end of your rope, tie a knot and hang on.-

							Franklin Delano

More information about the samba-technical mailing list