Codepages in 2.2.1a

Maksim Yakubenko yak at
Wed Aug 1 14:10:32 GMT 2001

Hi !

I've encountered a problem whith samba 2.2.1a
on Solaris 2.6 (Sparc):

I'm using Russian locales on Solaris and Windows
(koi8-r on Solaris and win1251 on Windows)

Here is  a part of my smb.conf:
    netbios name = TAZ
    workgroup = TG
    server string = Samba PDC TEST

    code page directory = /usr/local/samba/etc/codepages
    client code page = 866
    character set = KOI8-R

    log level = 2
    log file = /usr/local/samba/var/%m.LOG

    os level = 64
    preferred master = yes
    domain master = yes
    local master = yes
    security = user
    encrypt passwords = yes
    domain logons = yes
    logon path = \\taz\profiles\%u

    admin users = root 

    logon drive = Z:
    logon home = \\taz\%u
    logon script = logon.bat

    map archive = no
    nt acl support = yes

    unix password sync = yes
    smb passwd file = /usr/local/samba/etc/smbpasswd
    passwd program = /bin/passwd %u
    passwd chat = *password:* %n\n *password:* %n\n
    passwd chat debug = yes

    add user script = /usr/sbin/useradd -g ntpc -c Machine -d /dev/null
-s /bin/false %u

    path = /usr/local/samba/lib/netlogon
    writeable = no
    write list = root
    path = /usr/local/samba/export/ntprofile
    writeable = yes
    create mask = 0600
    directory mask = 0700

With this config samba 2.2.0 worked just fine
with codepages -- when I create a file or dir with Russian 
letters from Windows 2000 on my Samba server - it's
name was showed perfectly both in Windows Explores and 
in Solaris (when LC_ALL=koi8-r)

This worked in Samba 2.0.6 and 2.2.0 but
it does'n work anymore with Samba 2.2.1a.

(As client I'm using Win200 SP2)

Now them I'm trying to create a file or a dir
with Russian name Explorer shoes me something strage (unicode?)
Solaris ls shos just '?????????????' symbols as file- or dir- name.

Could you please help me with this ?

Maxim Yakubenko

More information about the samba-technical mailing list